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ADA ACCESSIBILITY DESIGN
Accessibility Design
What it means and why it is necessary
All Documents that go online as PDFs instead of HTML need to be made accessible. 
This is so that people with visual impairments or disabilities can receive the same visual 
information as someone who doesn’t.

File Info and Document Title
Add document information in File>File Info>Basic. This allows screen readers to read 
the title of the document unopened on or in the desktop. Furthermore, the author, key 
words, and security may be added here.

The document title is different than 
the file name, for example, this file’s 
name is NAU Strategic Plan Wallet 
Card – Accessible.PDF but when the 
document is opened, the title shows as 
2018-2025 NAU Strategic Plan Wallet 
Card (Fig. 1). The reason there needs to be a document title is that it can be descriptive 
of the content within the document, versus how the file is named. How we name the 
files that we create has no meaning to people outside marketing, they do not know that 
we have the date then project number, then the project name, and so if that was how 
the document is titled, it wouldn’t be as informative and concise.

Fig. 1 File name vs Document Title

Figure Alternate Text 
Each photograph, image, vector, etc. needs to have alternate text that describes what 
is in the image. This is so that people with visual impairments or disabilities can know 
what is in the image without necessarily seeing it. The more concise the alt text is, the 
better, however, it does need to be meaningful enough to relay the content of the image. 

The Alt Text Source needs 
to have “Custom” selected.

Giving the figure a title helps to 
keep track of which figure is which 
in the tags list.

Fig. 2 Alt text menu in InDesign and Acrobat

In InDesign right click the item that needs the alt text and go to Object Export 
Options. Go to the Alt Text section and make the source Custom. (Fig. 2)

To add the alt text in Acrobat, go to the tags panel and select the figure that needs the 
alt text. Right click and go to properties. At the bottom of the list. Make sure the type of 
item it is listed as a figure and then add the alt text in the correct box. You can also give 
the figure a title, which makes it easier to find again in the tags panel.

Artifacted Figures
These are objects that are within the 
document for visual purposes, but are not 
necessary for information. This can include 
colored boxes, lines, overlays, and other  
decorative items.

In InDesign, go to Object Export Options 
(Fig. 3) and select Tagged PDF. In the Apply 
Tag: section, change it from From Structure 
to Artifact.

Fig. 3 Menu for artifacting an object.

Color Contrast
An important aspect of color on the Web for both low vision and colorblind users 
is sufficient contrast between foreground (text or graphics) and the background. 
Maximum contrast is black versus white. The results of running the NAU palette 
through a checker is shown in Fig. 4.
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X indicates that it is approved for both small (minimum 12px, 9pt) and large text (e.g. zoomed to 200%)
O indicates that the color combination is only approved for large text.

Fig. 4 Table showing the color combinations of the NAU color palette if and how they are 
approved for accessibility or not.

https://nau.edu/


Anchored Images
Use the Anchors to Images tool to allow screen readers to read images in flow of 
text. This feature allows a screen reader to read the alt text description of the picture 
at the appropriate location in the associated content. Be sure to place this Anchor 
after or before a complete sentence.

Logical Reading Order
When a PDF is exported from InDesign and reading order is not taken into 
consideration, there is a chance that how someone reads the page with an assistive 
device is not in the order that is intended. Tabs are often used to navigate a PDF and 
they need to parallel the reading order. 

In InDesign, using fewer text boxes, and threading them together helps with the flow 
of the reading order, however, if the document has not been designed this way, the 
reading order can be checked and changed in the layers panel. As a note, it is easier to 
create a logical reading order if all text is in one layer. The reading order goes from the 
bottom up; the items that need to be “read” first should be at the bottom of the list in 
order for the correct reading order when exported. (Fig. 5)

The title of the piece 
on the front page 
was created through 
separate text boxes, 
but should be read 
from the bottom up. 
This will put the logical 
reading order as “2018 
- 2025 Strategic Plan 
OneNAU Side by Side”

Images in the 
background, that 
will be seen first.

Fig. 5 How to create the reading order in InDesign Layers

In Acrobat, go to the Order panel to manually check that the order is correct. If it 
isn’t, select the item in the panel and move it to the proper position. 

In the top of Fig. 6, we see that in the small squares the reading order, the blue 
background image is read first, followed by Our Mission and its text, then Our 
Vision and its text, and so on. On the left is the order panel where each item can 
be rearranged to make sure that it is within the correct reading order.  

Acrobat has a habit of separating each line as a different item. While this is 
technically correct for a logical reading order, simplifying the document into fewer 
tags is better. To merge them together into a paragraph or section, select the 
objects you want to merge in the order list, right click and select the tag that the 
items should be.

The boxes 
containing 
numbers show the 
reading order. You 
can also see it in 
the list on the left 
side of the image.

Select [3] – [11], 
right click and 
select Tag as 
text/paragraph

Fig. 6 Merging text lines together in Acrobat before and after.



Paragraph Styles/Character Styles 
A paragraph style includes both character and paragraph formatting attributes and can 
be applied to a paragraph or range of paragraphs. A character style is a collection of 
character formatting attributes that can be applied to text in a single step. Paragraph 
styles can be added to existing text and character styles can be added in addition to a 
paragraph style such as bold or italic text, hyperlink, and/or character color.

Tags
Everything in a document needs a tag so that a reader and assistive devices know what 
is a header versus a figure versus a paragraph, etc.

In InDesign, tags can be assigned in each paragraph style under Paragraph Style 
Options>Export Tagging (Fig.7). The tags that should be used are the same as with 
coding, H1 for a title or level one header, H2 for a sub header, P for paragraph, etc. 

Fig. 7 Paragraph style option tagging in InDesign

Using styles will also help with the reading order and will be less work in Acrobat. Not 
only will they help with pretagging text, but they will also eliminate the step shown in 
Fig. 6 of needing to merge together the different lines of text. 

Lists 
Do not convert bulleted or numbered lists to text in InDesign. Be sure to create a 
Paragraph Style for bulleted and/or numbered lists. Items that are bulleted or numbered 
will automatically export to Acrobat as a list with list items. If there are any errors, they 
can be edited in the tags panel in Acrobat.

Hyperlinks 
Hyperlinks need to be written out as the full link as well as made a live link that will go 
to the page or email when clicked. (Fig. 8)

Go to our marketing website for more information.
Go to nau.edu/marketing for more information.
Fig. 8 The link is incorrect on the top line because it is not written out, the bottom is correct so 
that someone can see what the address is of the site they need to visit. Note that the top line 
has the default style of hyperlinks created by InDesign. It can be changed in the paragraph or 
character styles of the document, as shown in the second line.

Go to Window>Interactive>Hyperlinks to open the panel in InDesign. Select and copy 
the text that is the link and then copy the address into the URL: box. To change it from 
being a URL into an email link in the panel, select the link, right click, and go to Link To: and 
choose Email. Add alt-text in the Accessibility tab in the Edit Hyperlink (Fig. 9) panel. 

Fig. 9 Paragraph style option tagging in InDesign

InDesign automatically defaults the links to be underlined and have a blue color 
swatch if text styles have not been applied. Choose the hyperlink style that you set up 
previously in character styles.

http://nau.edu/marketing
http://nau.edu/marketing


Tables
Accessible tables are simple, rather than complex, have an identified header row, and 
include a table summary, either as a caption or as alt text. The table needs to contain 
information that should be within a table, versus using one for layout purposes. The data 
table cannot have any spanned or merged row or column cells because it is difficult for 
screen readers to navigate (Fig. 10). These techniques help screen reader users read 
the information contained in the table.

Layout Table

Correct Data Table

Fig. 10 Layout table versus data table. Note that in the layout table the last column is merged into one cell, 
where as in the correct data table, that column has separate cells that correlate with the row information.

Export
When exporting the PDF from InDesign, make sure that the document exports as an 
Interactive PDF. (Fig. 11)

In the Export to Interactive PDF panel, General>Options verify that Create Tagged 
PDF and Use Structure for Tab Order is checked. Double-check that the Compression 
is JPEG quality: Maximum and the resolution is 300 ppi. Also, in Advanced you will see 
if the file info has been updated for the document title.

Fig. 11 Exporting document

File Naming
For files that are being created or converted for ADA compliance, please label the end of 
the file name with “_ADA Review” and put it in a separate file folder within the project 
on the server entitled “Accessible files.” Once the PDF file has been confirmed as 
compliant, label the end of the file name “_ADA Final” before you post it to Workfront. 
Please remember to add a red dot to the final INDD and PDF files on the server.



Design for Accessibility Checklist
FILE INFO

•	 File > file info

» Document Title (mandatory)

» Author (Northern Arizona University)

» Keywords (use your best judgement and make sure they correlate with 
			   the piece)

CREATE ALT-TEXT AND ARTIFACT FIGURES

•	 Simple yet meaningful description of images

•	 Logos/photos/graphs 

» Multiple transparency layers over photo: export as jpg and re-import 

» Right-click (or CNTRL click) > object export options > Alt text > “custom” 
			   (in dropdown menu) > add alt text 

•	 Artifact design elements

» This includes color boxes, decorative icons, individual transparencies, 
			   lines, etc.

•	 Right-click (or CNTRL click) > object export options > tagged PDF > apply 		
	 tag > choose “artifact”

COLOR

•	 Change text to make sure color combinations/size are accessible

•	 Use Adobe Color Accessibility Tools 
	 (color.adobe.com/create/color-contrast-analyzer) or download the 

TPGi Colour Contrast Analyser (tpgi.com/color-contrast-checker)
	 to check color contrast 

ANCHOR IMAGE TO TEXT

•	 If you want the image to read first, anchor it to the beginning of the caption text. If 	
	 you want it to read after, anchor it to the end of the text.

READING ORDER IN LAYERS

•	 Layer the correct reading order from the bottom to the top in the Layers panel

» You can combine the layers for this step if it is easier for you

» Re-order inside the layers panel

THREAD THE TEXT OR COMBINE TEXT BOXES

•	 The fewer dislocated text you have the better

CREATE ORDER WITH ARTICLES

•	 Windows > articles

» Click and drag each element of the reading order from top to bottom 
			   (opposite from the layers reading order) into the articles panel

» Give “new articles” logical names (ex: “Header” can include articles in 		
			   order for logo, header image and H1 text)

» To include an article while exporting, in the Articles panel, select the article, and 	
			   then select Use for Tagging Order in Tagged PDF.

PARAGRAPH/CHARACTER STYLES

•	 Window > styles > paragraph styles

» New paragraph style options

*	 Style name

*	 Set “basic character formats”

*	 Character color, etc.

•	 Create a paragraph style for lists

CREATE HYPERLINKS

•	 Window > Interactive > hyperlinks 

•	 New hyperlink panel > add URL > designate as URL or email address > link to 	
	 Paragraph style (or character style if necessary) > add alt-text in Accessibility tab

» Logo

» URLs 

» Emails and phone numbers

TABLES

•	 Format it as a data table only 

•	 Setting up table styles can save time later

» Simple is better, try to avoid graphic elements

» Do not merge cells

» Make sure you set up the headers as a separate table style from the cells (this 	
			   helps later with reading order)

EXPORT PDF

•	 Interactive

» Tagged PDF

» Structure from tag order

https://color.adobe.com/create/color-contrast-analyzer
https://www.tpgi.com/color-contrast-checker/


Design for Accessibility Checklist (cont.)
OPEN IN ACROBAT

ACCESSIBILITY TOOLS

•	 Tools > accessibility

•	 View > show/hide > navigation panel > show “order” and “tags” and “articles”
 	 as needed

READING ORDER

•	 Double check

» Re-order as necessary in PDF or INDD file

» NOTE: every time you re-order and make changes in the INDD files, you will	
			   have to re-export and remake any PDF changes that you had made previously. 	
			   It is best to make PDF changes at the very end and make as many changes as 	
			   in INDD as possible.

CONTENT

•	 Delete empty containers

TAGS

In Acrobat go to the Tags panel to clean up the tags and properly nest them (Fig. 11). 
The tags should be nested as tags>Document>Art>Sect. Each page should be a 
different <Sect> and contain all the objects on that page, in the correct reading order. 
Acrobat contains each text item within a <p> tag, which is unnecessary unless it is a 
paragraph.

•	 Delete empty tags

•	 Alt text/figure check

ACCESSIBILITY FULL CHECK

•	 Mark things fixed, check again, or double check in InDesign. Acrobat provides 	
	 helpful information if there is that may seem unfamiliar.

•	 Ask questions if needed

•	 Do this and re-export as needed until complete

YOU’RE DONE!

Fig. 11 Acrobat’s list of tags on the left, and on the right it has been cleaned up and made succinct.

Figures should 
be contained 
within their 
corresponding 
section

Header tags do 
not need to be 
nested within a 
<p> tag.

Unnecessary 
repetition of 
<p> tag.

Contains all 
the tags for the 
second page of 
the document with 
the correct reading 
order.

Additional Resources 
How to Style Text Quickly with Shortcuts in InDesign (youtu.be/m7DBqE66C0Q)
InDesign How-To: Set Alt vs. Actual Text for Accessibility (youtu.be/Ca2PvPvsAic)
InDesign How-To: Use the Articles Panel for Accessibility (youtu.be/yI2NJomPXBQ)
Contrast Grid: Test Foreground and Background Color Combos for Color Contrast Compliance (contrast-grid.eightshapes.com)

https://youtu.be/m7DBqE66C0Q
https://youtu.be/Ca2PvPvsAic
https://youtu.be/yI2NJomPXBQ
https://contrast-grid.eightshapes.com/
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